Home     Contact     Forum     Projects     Experiments     Circuits     Theory     BLOG     PIC Tutorials     Time for Science     RSS     Terms of services     Privacy policy  
   
 Home     Forum     Projects     Experiments     Circuits     Theory     BLOG     PIC Tutorials     Time for Science   

Author Topic: PROBLEM PROJECT BUILD  (Read 5167 times)

0 Members and 1 Guest are viewing this topic.

Mutloob

  • Guest
PROBLEM PROJECT BUILD
« on: July 02, 2011, 12:24:50 PM »
WHEN I PRESSS F10 FOLLOWING ERRORS ON OUTPUT WINDOW

Debug build of project `I:\Electronics\decode pudn\LED SEQ\LED SEQ.mcp' started.
Language tool versions: MPASMWIN.exe v5.41, mplink.exe v4.39, mplib.exe v4.39
Preprocessor symbol `__DEBUG' is defined.
Sat Jul 02 14:08:06 2011
----------------------------------------------------------------------
Make: The target "I:\Electronics\decode pudn\LED SEQ\Led Sequencer.o" is out of date.
Executing: "E:\Program Files\Microchip\MPASM Suite\MPASMWIN.exe" /q /p16F88 "Led Sequencer.asm" /l"Led Sequencer.lst" /e"Led Sequencer.err" /o"Led Sequencer.o" /d__DEBUG=1
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\LED SEQUENCER.ASM 3 : Symbol not previously defined (_config1)
Error[126]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\LED SEQUENCER.ASM 3 : Argument out of range (not a valid config register address)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\LED SEQUENCER.ASM 4 : Symbol not previously defined (_config2)
Error[126]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\LED SEQUENCER.ASM 4 : Argument out of range (not a valid config register address)
Warning[207] I:\ELECTRONICS\DECODE PUDN\LED SEQ\INIT_NORMAL.INC 1 : Found label after column 1. (bank1)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\INIT_NORMAL.INC 9 : Symbol not previously defined (option_reg)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\INIT_NORMAL.INC 10 : Symbol not previously defined (pie1)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\INIT_NORMAL.INC 11 : Symbol not previously defined (pie2)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\INIT_NORMAL.INC 12 : Symbol not previously defined (ansel)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\INIT_NORMAL.INC 13 : Symbol not previously defined (txsta)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\P16F88.INC 417 : Symbol not previously defined (status)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\P16F88.INC 417 : Symbol not previously defined (rp1)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\P16F88.INC 418 : Symbol not previously defined (status)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\P16F88.INC 418 : Symbol not previously defined (rp0)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\INIT_NORMAL.INC 15 : Symbol not previously defined (intcon)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\INIT_NORMAL.INC 16 : Symbol not previously defined (ccp1con)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\INIT_NORMAL.INC 17 : Symbol not previously defined (t1con)
Warning[207] I:\ELECTRONICS\DECODE PUDN\LED SEQ\INIT_NORMAL.INC 20 : Found label after column 1. (bank2)
Warning[207] I:\ELECTRONICS\DECODE PUDN\LED SEQ\INIT_NORMAL.INC 24 : Found label after column 1. (bank1)
Error[116]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\INIT_NORMAL.INC 24 : Address label duplicated or different in second pass (bank1)
Warning[207] I:\ELECTRONICS\DECODE PUDN\LED SEQ\INIT_NORMAL.INC 29 : Found label after column 1. (bank0)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\INIT_NORMAL.INC 31 : Symbol not previously defined (rcsta)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\INIT_NORMAL.INC 32 : Symbol not previously defined (adcon0)
Warning[207] I:\ELECTRONICS\DECODE PUDN\LED SEQ\LED SEQUENCER.ASM 29 : Found label after column 1. (bank1)
Error[116]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\LED SEQUENCER.ASM 29 : Address label duplicated or different in second pass (bank1)
Warning[207] I:\ELECTRONICS\DECODE PUDN\LED SEQ\LED SEQUENCER.ASM 35 : Found label after column 1. (bank0)
Error[116]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\LED SEQUENCER.ASM 35 : Address label duplicated or different in second pass (bank0)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\LED SEQUENCER.ASM 38 : Symbol not previously defined (Carry)
Error[128]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\LED SEQUENCER.ASM 38 : Missing argument(s)
Error[113]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\MSECDELAYS4MHZ.INC 38 : Symbol not previously defined (Zero)
Error[128]   I:\ELECTRONICS\DECODE PUDN\LED SEQ\MSECDELAYS4MHZ.INC 38 : Missing argument(s)
Halting build on first failure as requested.


I USE MPLAB 8.70

kam

  • Administrator
  • Hero Member
  • *****
  • Posts: 1849
Re: PROBLEM PROJECT BUILD
« Reply #1 on: July 02, 2011, 12:26:36 PM »
Read Creating a new project in MPLAB, pay attention to step 10


Mutloob

  • Guest
Re: PROBLEM PROJECT BUILD
« Reply #2 on: July 02, 2011, 12:33:31 PM »
thankyou

now all is ok

thanks again